Loading...
 
[Show/Hide Left Column]
[Show/Hide Right Column]

Print

WIND WAVES Manual

 

Downloading Data

 
Before starting to use WIND WAVES, you must download data from the Internet. Home page of WIND WAVES is the best place: http://lep694.gsfc.nasa.gov/waves/waves.html. The IDL save files are found from the left side of the page and there are files for three different sensors of the WAVES instrument; RAD1, RAD2, and TNR. The data files are in form yyyymmdd.vvv, where vvv is the name of the sensor. Copy the link location of the file you want to get and go to the terminal.

In terminal, copy the data to your computer with this command. Notice that the data will be copied in the same directory you are in, we want it to be /data/ssw/sswdata/wind/.

wget URL-address

For example:

 

After copying all the files you want, you can run the SolarSoft by typing sswidl in the terminal. Before starting to analyse the data you must add a file path to solarsoft to use functions and procedures related to WAVES.

ssw_path,'/data/ssw/radio/wind/'

 
Last thing to do before starting is to enter following command. If this command isn't given, this error will appear: "Attempt to call undefined procedure/function: 'DIFF'".

.r/data/ssw/radio/wind/diff.pro

 

Running Wind WAVES

 
Now run Wind WAVES with command:

xwavesds

 

Plotting Data

 
Wind WAVES is a partly widget-based program and will open in a new window. In this window choose File -> New Plot. After this move back in the terminal, where the program will ask some questions about the image you are going to plot.

  • First thing to enter is the name of the sensor(s) used. Type rad1, rad2, both (for rad1 and rad2), tnr, or all.

 

  • Now the program asks the starting date, which must be given in form yyyymmdd.

 

  • Next you need to choose the starting time. The program suggests zero in the square brackets. To accept suggestion, press enter. Otherwise type the time you want in hours (for example 12 or 15.7) and press enter.

 

  • Next step is to give the ending date. The program will suggest the same date you choose for starting. Accept this date by pressing enter, or type the date you want.

 

  • Naturally, you now need to give the ending time. Accept the suggestion or give a time of our own in hours.

 

  • Next thing to do is to choose the limits for frequency. First give the lower limit, or accept the the suggestion. Then type the upper limit (again the suggestion is accepted by pressing enter). Notice that the both limits must be given in the units of kHz.

 

  • Now you are asked to choose the type of the frequency axis. Option are linear (type lin), logarithmic (log) or 1/f (1/f). Logarithmic axis is suggested and can also be chosen by pressing enter.

 

  • Last thing is to give the averaging interval in minutes. Suggestion in square brackets can be accepted as described above.

 

  • Now program collects the data and plots it in the plot window.

 

Making settings

 

  • If you want to save the plot, choose File -> Save as PS / Save as gif /Save as png.

 

  • Choose Options -> Rescale if you want to change the scale of intensity relative to baclround. The program then asks you to give the new minimum and maximum values in units of dB. You enter them in terminal in form min, max

 

  • Choose Options -> New Colors to open window for choosing color palette (also opens by command "xloadct" in terminal). Choose color form the list by clicking the line. Notice that colours are only visible when the cursor is on the top of the plot window.

 

  • Choose Options -> Sub-interval to shorten the time axis. The new limits are shown by clicking the plot with left mouse button.

 

  • Choose Options -> Frequency Cut if you want to get a plot of intensity (dB) above backround as a function of time at some specific value of frequency. You need to choose the frequency you want by clicking th plot with mouse.

 

  • In addition to all this, you can use the usual IDL-commands to edit the plot. For example you can plot some curves over it by using the oplot-command.

 


Created by mevali. Last Modification: Friday 20 of July, 2007 12:25:15 UTC by mevali.