Loading...
 
[Show/Hide Left Column]
[Show/Hide Right Column]

Print

RHESSI Manual

 

Downloading Data

 
The easiest way to download RHESSI data for analyzing is to use RHESSI Data Search tool (http://hesperia.gsfc.nasa.gov/getfiles/rhessi_data_search.html). The software searches all the needed data files for the certain time interval given by the user. The URL-address of the data is sent to user's e-mail. Note that the data is available for downloading at the URL only for 48 hours.

Data can be downloaded at terminal by command:

wget URL-address
For example:

 
Data is compressed in zip-format and can be unpacked by command:

unzip file
For example:
unzip 20070628_063709.zip

 
Downloading and unpacking the data is good to do at the same directory you want to save your data to avoid moving it here and there.

Data can also be downloaded from http://surfwww.mssl.ucl.ac.uk/surf/data_request.html, ftp://hercules.ethz.ch/pub/hessi/data/, and http://hesperia.gsfc.nasa.gov/hessidata. When downloading data from these places, it is important that user knows what files are needed. For a certain time interval, you need all the Level-0 data files of the interval and also Observation Summary Data file (hsi_obssum...).

The Level-0 data file are in form hsi_yyyymmdd_hhmmss_nnn.fits, where yyyymmdd is the date, hhmmss time and nnn is the version number of the fits-file. Observing Summary Data files are in form hsi_obssum_yyyymm_nnn.fits where obssum means of course observing summary and yyyymm is the year and month of the observation and nnn again the version number.

Checking and Setting Environment Variables

 
It is very important to check the environment variables before using the RHESSI Data Analysis Software for the first time. If the environment variables aren't set right, the software doesn't find any data files.

The environment variables we are interested in this place are
HSI_DATA_ARCHIVE and HSI_DATA_USER. HSI_DATA_ARCHIVE should point to the top-level directory under which the Level-0 data files are located. For most users, it is best to set the HSI_DATA_USER to point in the same directory that HSI_DATA_ARCHIVE. (See more details from http://hesperia.gsfc.nasa.gov/ssw/hessi/doc/faq_hessi_datafiles.htm)

You can check where the environment variables point by typing the following command in the IDL (sswidl):

hessi_var

 
The command prints all the environment variables on the terminal. There should be next two lines:

$HSI_DATA_ARCHIVE = /data/ssw/sswdata/hessi

$HSI_DATA_USER = /data/ssw/sswdata/hessi

If this is not the case, user must set the variables itself. There are two ways to do it; either do it every time when running RHESSI Data Analysis Software (option 1) or save the information in the file that is read automatically every time SolarSoft is started (option 2).

Option 1

This must be done every time before starting SSW (by command sswidl) in the terminal. Give commands:

setenv HSI_DATA_ARCHIVE /data/ssw/sswdata/hessi

 

setenv HSI_DATA_USER /data/ssw/sswdata/hessi

 
NOTE: /data/ssw/sswdata/hessi -directory must be replaced with the directory where your data exists or where you are going to download it.

Option 2

In the terminal, open .cshrc-file to Emacs with command:

emacs .cshrc

 
The Emacs starts and the user must click the screen after configuration to get to edit .cshrc. Now write in the file (somewhere near the end of it) the same lines that occur in the tack 1. Then save with Ctrl+x,Ctrl+s (or click the save-icon on the toolbar).

RHESSI Graphical User Interface (GUI)

 
Widget-based software is started from the IDL (sswidl) by command:

hessi

 
Then the Main Window should open (configuring can take a little while). If you wish, you can also use RHESSI Data Analysis Software from command line, see instructions below.

Plotting Observing Summary Data

 
Observing Summary Data is often used to coarse flare searching. Data is faster to handle for long time intervals and after plotting curves it is easy to choose the exact time interval to use, for example, in high resolution images. The two ways to plot curves are as follows.

Select Observation Time Interval

 
If you know a certain time interval you want to study, it is best to choose this option to plot Observing Summary Data. First choose File -> Select Observation Time Interval. In a new window opened (Select Observation Time Interval), use Start and End buttons to choose the starting and ending times or type them directly in the windows next to those buttons. Notice also that after you did this, the software automatically chose the flare (id.number), that occurs in the given time interval, in the window next to Flare Selection button.

Now choose the curve type (default: Count Rate) you want from the Select Data to Plot -pull-down menu. After that click Plot Observing summary Data -button and the software will plot the curves from different energy bands in the Main window.

Flare Selection

 
Curves can also be plotted by giving the id. number of the flare. Choose File -> Select Observation Time Interval and type the flare number in the window next to Flare Selection button. If you don't know the flare number, you can also click Flare Selection button and type needed information in the new window (Flare Select and List). The same window is opened if you choose File -> Browse Flare Catalog.

After choosing the flare click, you can choose the curve type and plot the curve as described above.

More Settings and Hints

 

  • Because the Select Observation Time Interval window will stay opened when the curves are plotted, it is easy to change only the wanted options from that window. Especially this helps when you want to plot several type of curves from the same time interval.

 

  • When selecting observation time interval you can type the starting time and duration (in seconds) instead of starting and ending time.

 

  • When clicking the right mouse button on the top of the image (when no tools are in use), the coordinates of the point are printed both in the image and in the terminal.

 

  • After plotting the curve, some options can be changed from the Plot_Control menu. All tools (e.g. zoom) can be turned off by clicking the right mouse button on the top of the Main window.

 

    • For zooming the curve, choose Zoom and follow the instruction at the bottom of the Main window ("Click and drag left mouse button to define zoom area").

 

    • Uzoom control restores the image to the original state (not to the previous state).

 

    • By choosing XY Plot Display Options you can make more options in a new window that opens. You can change for example the scalings and limits of the axis, place of the legend and choose different energy bands. You can also edit font size and the thickness of the curves.

 

Plotting Light Curves

 
Obtaining light curves starts with choosing File -> Retrieve/Process Data -> Lightcurves. Now the Lightcurves window opens and you can make here the settings you wish. Again the plot is done in the Main window. By default the settings in Lightcurves window are as follows: the curve is plotted for the full observation time interval with 0.1 second time bins and there is only one large energy band (6-50 keV). With these settings plotting is taking a lot of time and that is why you should make some changes. Try choosing some bigger number in the Time Resolution box (I tried 2.00) and some narrow band in Energy Bands (for example 12-25 keV).

It is assumed here, that you have first plotted some observing summary data etc. of the current flare and that the observation interval is so automatically chosen right (at the top of the Lightcurves window). If this is not the case, change it by clicking the Change-button. The Observation Time Interval Selection window opens and you can choose the time interval as shown in the Plotting Observing Summary Data section.

Making Changes to Settings

 
Changing Time Resolution is easy. You can either click the ^-button and choose the number you want from the drop-down menu or just write the number in the box. Energy Bands are changed by clicking the Change button next to it in which case a new window opens (Select Energy Interval(s)). The easiest way to change the energy interval is to choose one from the "Standard" drop-down menu, or if there isn't the band you want just write the Low and High values in the boxes next to the Standard button. All these are found at the lowest part of the Select Energy Interval(s) window. After choosing the Energy Band(s) you must still click the Replaca List button and after that Accept button and the window will close automatically.

Sometimes we need to be sure to avoid any problems with the modulation of the flux affecting the light curve. To do this we need to make the plot with time bins just one rotation period long (see section Determining Spin Period). So you need to determine the spin period and enter it in to the Time Resolution box in seconds.

Determining Spin Period

 
Spin-periodis easy to determine by IDL-command:

pmtras_analysis,'hsi_yyyymmdd_hhmmss_nnn.fits',/NO_STARID

 
Where the fits-file is the one containing the peak time that is the file with time that is the last one before the peak. You find the peak time either from the catalogues or plotting observing summary data (see section Plotting Observing Summary Data). When using observing summary data, you can determine the peak time from the plot or use the time the software gives in the Observation Time Interval Selection window after choosing start and end times.

For example:

pmtras_analysis,'hsi_20040327_031440_001.fits',/NO_STARID

 
Here the peak was at 04:17.

After giving the command a new window opens. The plot in this window shows the spin period as a function of time. You have to find the peak time from the x-axis and the correspoding spin period (y-axis value), which is the value you need. For my exmaple data from the day 27.3.2004 (flare number 4032715) the spin period is about 4,0673 s

 

Locating Flare

 
The location of the flare on the dics of the Sum is needed for exmaple to produce high resolution images of the flare. To start, open Imaging window by choosing File -> Retrieve/Process Data -> Image. The opening Imaging window is the same one you use to make high resolution images, but now we just use it to make rough image of the Sun.

It is assumed here, that you have first plotted some observing summary data etc. of the current flare and that the observation interval is so automatically chosen right (at the top of the Imaging window). If this is not the case, change it by clicking the Change-button. The Observation Time Interval Selection window opens and you can choose the time interval as shown in the Plotting Observing Summary Data section.

For the coarse image, use the coarsest collimators that are 6, 7, 8, and 9 (you don't have to use them all). Collimators are chosen by clicking the Change button next to Collimators and Detector Front/Rear Segments Selected, in the Imaging window. Now a new window named Collimator/Detector Options opens. In this window, select collimators 8 and 9 (and unselect others) and also select Front. Then click Accept and the window will automatically close and you should see the new collimator settings in the Imaging window.

Next you need to change the settings of the image and pixels. Click the Change button little lower than the previous one (still in the Imaging window). Image Size and Location Options window shoul open. Select Pixel Size 32x32 and Image Dimension 64x64 by using the drop-down menus. By default the Square Pixels and Square Map should be selected. Unselect Use XY offset from Flare Catalog and check that Offset of map center from sun center is X = 0.00 and Y = 0.00. Click Accept and the window will close.

In the Imaging window, check that following setting are right (if not, change them by drop-down menus or by change button):

  • Energy Band: 12-25 keV
  • Image Algorithm: Back Projection
  • Flatfield: Enabled
  • Modpat\_skip: 1
  • Phase Stacker: Disabled
  • Cull: Disabled
  • Weightning: Uniform
  • Tapering Width: 0.00
  • Local Average: Enabled
  • Variable Flux Correction: Disabled
  • Decimation Correction: Front
  • Rate-based BProj: Disabled

 
After all this, click Make/Plot Image butoon in the Imaging window and the Image is plotted in the Main window. You should see the source of the flare bright in the image. The yellow or red circle drawn in the image describes the disk of the Sun. You can determine the coordinates of the flare by moving the cursor on the top of the flare and clicking the right mouse button. The coordinates should now come up next to flare and also in the terminal. For data at 27.3.2004 the coordinates were about (x,y) = (236, -60).

If you can't see the flare source, first try changing the settings in the previous list and the number of collimators. If it doesn't help try these two options:

Option 1

Click Set Params Manually button at the bottom of the Imaging window. Warning window opens and you must choose Yes to continue and open the Xstruct window where the parameters can be changed. These parameters are very important for the proper working of the software. Don't change them if you don't know what you are doing! Change DBASE in the AS_ROLL_SOLUTION box to PMT and then click Commit in the upper left corner. The window will close. Other settings will be just right described above.

Option 2

Click Set Params Manually button at the bottom of the Imaging window. Warning window opens and you must choose Yes to continue and open the Xstruct window where the parameters can be changed. These parameters are very important for the proper working of the software. Don't change them if you don't know what you are doing! Make several changes:

  1. enter spin period (see instruction in section Determining Spin Period) in the AS_SPIN_PERIOD box
  2. enter FIX in the AS_ROLL_SOLUTION box
  3. enter 3.6 in the AS_ROLL_OFFSET (this is not any accurate number and changes from flare to flare, but this may be used)

Click Commit in the upper left corner. The window will close. Other settings will be just right described above.

 

Plotting Images

 
Notice that for making high resolution images, you must first locate the flare as was advised in the previous section.

It is assumed here, that you have first plotted some observing summary data etc. of the current flare and that the observation interval is so automatically chosen right (at the top of the Imaging window). If this is not the case, change it by clicking the Change-button. The Observation Time Interval Selection window opens and you can choose the time interval as shown in the Plotting Observing Summary Data section.

Select File -> Retrieve/Process Data -> Image to open Imaging window. By default the Image Time Interval is set to be 4 seconds (2s both sides of the peak). If you want to change the interval, click Change button next to the Image Time Interval (you can also choose multiple intervals) and use the Start and End buttons of the opening new window to select the time interval. After that click Add to List if you want to keep also the original interval(s) or Replace List if you want only the interval you just detemined.

Sometimes you may want the time interval to be an integer number of rotation periods (see section Determining Spin Rotation). By doing this you can be sure to sample all of the Fourier components uniformly. Again you must click the Change button next to Image Time Interval. In the opening window, select the start time you want (Start button) and then enter duration that is, for exmaple, five times the spin period.

Next you must enter the location of the flare on the disc of the Sun (see section Locating Flare). Click Change button in the Imaging window next to Pixel Size and Image Dimension. The window Image Size and Location Options opens. Select Use XY offset from flare catalog if not already selected and enter the coordinates of the flare in the X and Y boxes. Then click Accept and window closes.

Then choose collimators you want (click the Change button next to Collimators and Detector Front/Rear Segments Selected and select for example collimators 3,4,5,6,7 and 8, click Accept). Also other settings can be changed by drop-down menus or Change buttons. After this click Make/Plot Image(s) and wait. The image will be plotted in the Main window, but the plotting make take a while (depending on the settings). You may follow the plotting process in the terminal.

More Settings

 
You can make different images by changing some of these( in addition to changing Image window settings)
From the Main window, Plot_Control drop-down menu:

  • Choose Image Colors and pick up one color from the list of the opening window. The color will only be seen when the cursor is on the top of the Main window.
  • Choose Image or Spectrogram Profiles -> Rows or Columns and you will get a spectrogram in a little new window. Spectrogram profile is either in row or column direction and this can be changed by clicking the left mouse button on the top of the image in the Main window. If you choose Image or Spectrogram Profiles -> Any Angle you can choose the angle relative to axes in which the spectrogram goes.
  • See also instructions in section Plotting Observing Summary Data -> More Settings and Hints.

 

Using RHESSI Data Analysis Software from the Command Line

 
This section is especially for those who hate widget-based softwares. For beginners I recommend RHESSI GUI.

Flare List

 
Flare list is used to choose the flares you want to study closer. After you have found the flares of your interest, you can download the data you need for analyzing. All the data for using flare list is already downloaded when the SolarSoft was installed.

The basic command for searching flares:

list=hsi_select_flare()

 
This command stores all the flares (their id numbers) that meet the given criteria (there is none) to list-variable. After that, the list-variable can be printed by command "print,list". Because we usually want to print the list, it is best to use following command which does the printing automatically:

print,hsi_select_flare()

 
So this is the basic command for searching and printing the flare list.

There are some examples next, to show who to add the criteria in the command to sample the flares you are interested in.

Example 1: Searching for the flares by their energy.

 
There are two ways to search flares with energy over 7000 keV.

Option 1, By just one command (uses the basic command, I recommend):

print, hsi_select_flare(energy_hi_range=[7001,1.e7])

 
This command tells to search flares with the highest (hi) energy between 7001 and 1e7 (in practice over 7001).

Option 2, By 3 commands:
Read Rhessi Flare List to variable a:

a = hsi_read_flarelist()

 
Store the indexies, which have the highest energy ovar 7000, to the index-variable:

index = where (a.energy_hi[1] gt 7000.)

 
Print the id number fields of those elements that have their index in the index-array:

print,a[index].id_number

 
So here we had:

  • gt = greater than
  • hi = highest energy, low = lowest
  • 1 in "index = where (a.energy_hi1 gt 7000.)" probably means the lowest energy band

 

Example 2: Searching for the flares by the peak time and peak countrate

 
Search for the flares with the peak between 2004 March 27 03:00 and 05:00 and that have the peak countrate greater than 500.

Option 1, By basic command:

print, hsi_select_flare(peak_time_range = ['2004/3/27 03:00', '2004/3/27 05:00'],peak_countrate_range=[501,1.e9])

 

Option 2, By 4 commands:

flare_ids = hsi_whichflare(['2004/3/27 03:00', '2004/3/27 05:00'])

 

flare_str = hsi_getflare(flare_ids)

 

index = where (flare_str.peak_countrate gt 500)

 

print,flare_str[index].id_number

 

About Keywords

 
Keywords can be added inside the parentheses of the function. Many keywords must be separated by commas.

For example

print, hsi_select_flare(energy_hi_range=[7001,1.e7],id_number_range=[3000000,5999999],total_counts_range=[5000,20000]

 
chooses the flares which have their highest ebergy over 7000, id number between 3 and 6 millions and total counts between 5 and 20 thousands.

A short list (examples) of keywords that can be used with hsi_select_flare

  • energy_hi_range=[7001,1.e7] See Example 1.
  • flag_incl=['A2', 'DF'] Chooses flares with flags in question. List of flags (name, 2 letter code, description) can be find by command "print,hsi_flare_flag_code(/expand,/sort)"
  • hour_range=[2,14] Picks up flares that occur between given hours, independent of date.
  • id_number_range=[m,n] Chooses the flares that have their id number between numbers n and m.
  • peak_countrate_range=[501,1.e9] See Example 2.
  • peak_time_range = ['2004/3/27 03:00', '2004/3/27 05:00'] See Example 2.
  • radial_dist_range=[400,800] Picks up flares which have their radial distance between given values.
  • start_time_range=['2004/3/27 03:00', '2004/3/27 04:00'] Chooses the flares that have started inside give time interval.
  • time_range=['27-mar-2004','28-mar-2004'] Picks up all the flares that occur in the time interval in question (don't have to be fully inside the interval). When this keyword is set, the other keywords that define starting, ending, or peak times, will not be noticed.
  • total_counts_range=[5000,20000] Chooses the flares with total counts between given values.
  • x_position_range=[500,800] Picks up the flares that have their x-position in the given range (in arcseconds in heliocentric coordinates).
  • y_position_range=[-58,200] Same than previous, but for y-position.

 
More keywords can be found via IDL with this pair of commands (you can also use the same command for other functions than hsi_read_flarelist):

flist=hsi_read_flarelist()

 

help,/st,flist(0)

 
More keywords and information about functions: http://www.darts.isas.jaxa.jp/pub/solar/ssw/hessi/idl/widgets/hsi_select_flare.pro

Plotting Observing Summary Data

 
There are two options to plot Observing Summary Data. The second one is mäybe little easier and shorter.

Option 1:

First create an obserivng summary object:

obs_obj = obj_new('hsi_obs_summary')
For example:
obs_maalis_27 = obj_new('hsi_obs_summary')

 
You can name the object as you like, but you must remember to use that name in following commands in place of obs_obj.

Determine the observation time interval:

time_interval = ['dd-mmm-yy hh:mm', 'dd-mmm-yy hh:mm']
For example:
time_interval = ['27-Mar-04 03:00', '27-Mar-04 05:00']

 
Next you need the data for plotting count rate. getdata function stores the Observing Summary Data for the interval in question, to obs_summ variable and some number data (maybe array of floating point numbers) to counts variable (can be printed by command "print,counts").

counts = obs_obj -> getdata(obs_time_interval=time_interval)

 
OR you can directly use certain fits-file of the time interval:

counts = obs_obj -> getdata(filename='hsi_yyyymmdd_hhmmss_nnn.fits')
For example:
counts = obs_obj -> getdata(filename='hsi_20040327_235100_001.fits')

 
Plotting:

obs_obj -> plot

 
Option 2: The same thing can also be done by just three commands:

obs_obj = hsi_obs_summary()

 

obs_obj -> set, obs_time_interval= [' 27-mar-2004 03:00:00.000', ' 27-mar-2004 05:00:00.000']

 

obs_obj -> plot

 

Settings and examples

 
Colours

If you want the curves to stand out better, you should try make them coloured. For this, it is easiest to use Ploman:

obs_obj -> plotman

 
Different kind of curves

Count rates aren't the only curves you can plot. By using class_name keyword, you can also plot for example modulation variance curves.

obs_obj -> plot,class='parameter'
For example:
obs_obj -> plot,class='mod_var'

 
Other parameters for class-keyword are:

    • roll_angle
    • roll_period
    • ephem
    • pointing

 
Count rate data is plotted by default, and after plotting other data, you can return to count rate data plots with the next command:

obs_obj -> plot,class='count_rate'

 

Corrected data with Plotman

obs_obj -> plotman, /corrected

 
Using Plotman to plot modulation variance data with flare flags

obs_obj -> plotman, class='mod_var', /eclipse, /flare

 
Change the settings of y-axis (limits, scale, style)

obs_obj -> plotman, yrange=[1,200], /ylog, ystyle=1

 
Plotting corrected count rate data manually as a function of time (0 = lowest energy band)

 

time = obs_obj -> getaxis(/ut)
data = obs_obj -> getdata(/corrected)
utplot, anytim(time, /ext), data.countrate[0]

 
List of the curve points

text = obs_obj -> list()

 

print,text

 
And for other type of curves:

text = obs_obj -> list(class='parameter')
For example:
text = obs_obj -> list(class='ephem')

 

Plotting Lightcurves

 
Create the lightcurve object:

ltc_obj = hsi_lightcurve()

 
Setting the energy band (in keV), by default 3-15000 keV

ltc_obj->set,ltc_energy_band=[m,n]
For example:
ltc_obj->set,ltc_energy_band=[12,25]

 
Determine the time interval:

ltc_obj->set,ltc_time_range=['dd-mmm-yyyy hh:mm:ss', 'dd-mmm-yyyy hh:mm:ss']
For example:
ltc_obj->set,ltc_time_range=['18-nov-2003 05:15:00', '18-nov-2003 05:30:00']

 
Set time resolution to plot an integrated light curve for the time interval with a n seconds resolution. By default 0.1 seconds.

ltc_obj->set,ltc_time_resolution=n
ltc_obj->set,ltc_time_resolution=1

 
Plot the curve:

ltc_obj -> plot

 

Making Images

 
Create image object:

im_obj = hsi_image()

 
Set the time interval, you want you want images from:

im_obj -> set, im_time_interval = ['dd-mmm-yyyy hh:mm:ss', 'dd-mmm-yyyy hh:mm:ss']
For example:
im_obj -> set, im_time_interval = ['27-mar-2004 04:16:00', '27-mar-2004 04:18:00']

 
Set the energy band you want to use:

im_obj -> set, im_energy_binning = [m,n]
For example:
im_obj -> set, im_energy_binning = [3,12]

 
Search the data:

data = im_obj -> getdata()

 
Plot the image with one of the following comands:

Basic plot

im_obj -> plot

 
Using Plotman

im_obj -> plotman

 
Using colours

im_obj -> plotman, colortable=n
For example (you can try different numbers):
im_obj -> plotman, colortable=5

 
Example 1:

loadct,3 & im_obj -> plot, xrange=[0,150], yrange=[-100,100], /limb,/cbar, legend_loc=0, title='Minnan_kuva', xtitle='xakseli', ytitle='yakseli', /no_timestamp

 
Here we have used these commands and keywords.

  • loadct,n Loads the color number n to the image. This command can also be given separatedly before or after making the image.
  • xrange=[m,n] Defines the limits for x-axis (similar for y-axis)
  • /limb Draws the circle that describes the disk of the Sun on the image.
  • /cbar Adds a bar with colour scale over the image.
  • legend\_loc=0 Places the legend on location 0 (=no where, location 1 = top of the image).
  • title='text' Adds a title on top of the image.
  • xtitle='text' Adds the given text under x-axis.
  • ytitle='text' Adds the given text under y-axis
  • /no\_timestamp Removes the timestamp that will be placed at the bottom of the image by default.

 
More keywords from:http://ips.ucsd.edu/help/ssw/hessi_p.html

Making Image Cubes

 
Making image cube can take quite a long time (I drow 180 images cube and it took some 90mins). BUT after making the image cube, you can easily browse images from different time or energy band.

Determine the time interval. It should be quite short, if you don't want to wait hours to get your images. 30 seconds might be good.

im_obj -> set, im_time_interval = ['dd-mmm-yyyy hh:mm:ss', 'dd-mmm-yyyy hh:mm:ss']
For example (this is from my test, interval is too long!)
im_obj -> set, im_time_interval = ['18-nov-2003 05:27:00', '18-nov-2003 05:29:00']

 
Set how many time bins the time interval will be split. In the example, the time interval is 2 minutes and one time bin 4 seconds, so we get 30 (=2*60s/4s) time bins. You get less images in the cube if you make the time interval shorter or/and tim bin longer. If you used 30 seconds as time interval, 5 seconds for time bin will be good.

im_obj -> set, im_time_bin = n.
For example:
im_obj -> set, im_time_bin = 4.

 
Set the number and range of the energy bands. In the example the bands are 3-6, 6-12,12-25 keV etc. totally 6 ones. Less energy bands means less images (number of images = number of energy bands x number of time bins)

im_obj -> set, im_energy_binning=[m1, m2, m3, m4,...,mn]
For example:
im_obj -> set, im_energy_binning=[3,6,12,25,50,100,300]

 
Now you can plot the first image of the cube (the other images are also made in the same process and plotting them takes only a little while). In the example chosen image is the one with third time (= 3x4s after starting = 05:39) and second energy band (= 6-12 keV)

im_obj -> plot, t_idx=m, e_idx=n
For example:
im_obj -> plot, t_idx=3, e_idx=2

 
To plot other images you just made, you can either use the previous command with different m and n, or open a new window with this command. In the new window you can easily choose the time and energy band you want just by clicking with mouse.

im_obj -> plotman, /choose

 
Saving of image into FITS-form.

im_obj -> fitswrite

 
Reading the saved image.

Option 1 Two commands

im_obj -> set, im_input_fits = 'hsi_image_test.fits'

 

data = image_object -> getdata()

 
Option 2 One command

images = hsi_image_fitsread(fitsfile='hsi_image_test.fits')

 
Sometimes when you are plotting image or getting data for it, this error might appear (in terminal).

\% Program caused arithmetic error: Floating illegal operand

 
Usually the image can still be drawn, but some changes in the settings may not work. The cause of the error can be bad data (try to download it again or from different place or new version) orsome specific energy band you are using (try plot the image with the defualt energy = no setting of im_energy_binning).

Making Spectra

 
Determine spectrum object:

sp_obj = hsi_spectrum()

 
Set observation time interval:

sp_obj-> set, obs_time_interval= [' dd-mmm-yyyy hh:mm:ss', ' dd-mmm-yyyy hh:mm:ss']
For example:
sp_obj-> set, obs_time_interval= [' 18-nov-2003 05:20:00.000', ' 18-nov-2003 05:30:00.000']

 
Set the lengths of the time bins. In the example one time bin is 0.2 seconds.

sp_obj-> set, sp_time_interval= n
For example:
sp_obj-> set, sp_time_interval= .2

 
Choose the collimators that are used (numbers and front/rear). In the example front segments 1,3,4,6,8, and 9 are chosen.

sp_obj-> set, seg_index_mask= [0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1, 0/1]
For example:
sp_obj-> set, seg_index_mask= [1, 0, 1, 1, 0, 1, 0, 1, 1, 0, 0, 0, 0, 0, 0, 0, 0, 0]

 

Set the energy band. In the example it's the lowest one.

sp_obj-> set, sp_energy_binning=n
For example:
sp_obj-> set, sp_energy_binning=1

 
Get the data:

data = sp_obj -> getdata()

 
Plot the spectrum, counts vs. energy.

sp_obj-> plot

 
OR
Plot spectrum, counts vs. time, and sum over different energy bands.

sp_obj -> plot, /pl_time, /dim1_sum

 
OR
Plot spectogram:

sp_obj -> plotman, /pl_spec

 

Different Plots

 
Determine spectrum object:

sp_obj = hsi_spectrum()

 
Define observation time interval

sp_obj-> set, obs_time_interval= [' dd-mmm-yyyy hh:mm:ss', ' dd-mmm-yyyy hh:mm:ss']
For example:
sp_obj-> set, obs_time_interval= [' 18-nov-2003 05:27:00.000', ' 18-nov-2003 05:29:00.000']

 
Get data. In the example the spectrum data unit parameter is flux (flux vs. energy plot), but you can also use parameters "counts" or "rate".

data = sp_obj -> getdata(sp_data_unit='parameter', /sp_data_structure)
For example:
data = sp_obj -> getdata(sp_data_unit='flux', /sp_data_structure)

 
Plot data.

sp_obj -> plot

 

Generic reading of data

 
Rhessi Level-0 files that are in FITS form can also be read with generic reading method. See SOHO.

Commands

 
From the next link you will find a page with just list of commands for different processes. No explaining, just commands.

Commands

 
http://www.darts.isas.jaxa.jp/pub/solar/ssw/hessi/idl/ All RHESSI Data Analysis Software IDL-commands

See more links from Links that might be useful


Created by mevali. Last Modification: Monday 23 of July, 2007 14:55:51 UTC by mevali.